Investigating Login Issues for Subset of Shoppers on B2B Catalyst Storefronts

Incident Report for BigCommerce

Resolved

This incident has been resolved.
Posted Jun 10, 2026 - 20:59 CDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 10, 2026 - 20:30 CDT

Identified

We have identified login issues on B2B Catalyst storefronts caused by latency and continue to work on a fix
Posted Jun 10, 2026 - 19:16 CDT

Investigating

Commerce Engineering is investigating an issue where a B2C user, or a B2B user under an unapproved company, is unable to log into a B2B Catalyst storefront.
Posted Jun 10, 2026 - 14:53 CDT
This incident affected: B2B Edition (B2B Edition - API, B2B Edition - Buyers Portal).