Phone Outage in Austin Contact Center
Incident Report for BigCommerce
Resolved
This incident has been resolved.
Posted Nov 07, 2019 - 17:18 CST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 07, 2019 - 14:33 CST
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 07, 2019 - 14:24 CST
Investigating
Our phone system is currently experiencing technical issues preventing agents from answering calls. We are currently working with our phone provider, but in the interim please note our live chat and web case queues are available. Thank you for your patience.
Posted Nov 07, 2019 - 14:11 CST
This incident affected: Client Services (Support Center).