Intermittent Availability Issues

Incident Report for BigCommerce

Resolved

Commerce Engineers identified and fixed the root cause of the intermittent errors affecting the control panel. This incident has been resolved.
Posted Jul 21, 2026 - 18:09 CDT

Investigating

Commerce Engineers are currently investigating an issue causing intermittent errors in PageBuilder and some other aspects of the control panel. Storefronts and the checkout experience are not affected.
Posted Jul 21, 2026 - 15:20 CDT
This incident affected: Control Panel.