BigCommerce engineers have confirmed the issue has resolved
Posted Feb 13, 2025 - 00:31 CST
Monitoring
BigCommerce engineers believe this issue to be related to the Braintree payment provider itself having an issue processing payments affecting the APAC region. We will continue to provide updates as they become available. Follow https://www.paypal-status.com/incident/production for more details on the issue itself.
Posted Feb 12, 2025 - 19:05 CST
Investigating
BigCommerce engineers are investigating an issue impacting Braintree credit card payments for a subset of stores.
Posted Feb 12, 2025 - 18:35 CST
This incident affected: Checkout & Payment Processing.