manage.bigcommerce.com unavailable

Incident Report for BigCommerce

Resolved

This incident has been resolved.
Posted Feb 06, 2025 - 21:20 CST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 06, 2025 - 21:13 CST

Update

BigCommerce engineers are continuing to work on a fix for this issue.
Posted Feb 06, 2025 - 20:02 CST

Update

We are continuing to work on a fix for this issue.
Posted Feb 06, 2025 - 18:38 CST

Update

We are continuing to work on a fix for this issue.
The following functions are affected:
manage.bigcommerce.com is unavailable
Domain name changes are unavailable
SSL certificate changes are unavailable
Trial and new store signups are unavailable
Posted Feb 06, 2025 - 18:20 CST

Identified

The issue has been identified and a fix is being implemented.
Posted Feb 06, 2025 - 18:04 CST

Investigating

We are currently investigating manage.bigcommerce.com being unavailable
Posted Feb 06, 2025 - 18:02 CST
This incident affected: Client Services (Client Portal).