Missing Data in Analytics Reports

Incident Report for BigCommerce

Resolved

This incident has been resolved.
Posted May 21, 2026 - 13:18 CDT

Identified

We identified two short periods of degraded visit tracking today, each under approximately 30 minutes. During these windows, visit processing was significantly reduced and some visit data was not recorded.

Affected areas:
Visit reports and Conversion reports may show incomplete data for the impacted periods.

The issue has been mitigated and processing has returned to normal.
Posted May 21, 2026 - 13:18 CDT

Update

We are continuing to investigate this issue.
Posted May 21, 2026 - 12:39 CDT

Investigating

BigCommerce Engineers are investigating an issue where analytics data is missing from the Control Panel Analytics Reports for a subset of stores.
Posted May 21, 2026 - 12:30 CDT
This incident affected: Reporting & Analytics.