Slow response times
Incident Report for BigCommerce
Resolved
This incident has been resolved.
Posted May 23, 2020 - 08:36 CDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 23, 2020 - 08:31 CDT
Investigating
BigCommerce engineers are investigating a increase in store response times. We will update with findings shortly.
Posted May 23, 2020 - 08:22 CDT
This incident affected: Storefront, Control Panel, and API.