support.bigcommerce.com outage
Incident Report for BigCommerce
Resolved
This issue has been resolved. The support site https://support.bigcommerce.com is now available.
Posted Nov 06, 2019 - 16:45 CST
Identified
BigCommerce engineers have identified an issue with our internal CMS provider which is currently being addressed. We will provide an update once support.bigcommerce.com is available again.
Posted Nov 06, 2019 - 14:22 CST
Investigating
BigCommerce engineers are investigating technical issues with support.bigcommerce.com.

BigCommerce support can be contacted at the following numbers:

USA & Canada
1-888-699-8911

Australia
1800-821-758

New Zealand
0800-001046

United Kingdom
0808-189-1224
Posted Nov 06, 2019 - 13:22 CST