Intermittent Availability Issues

Incident Report for BigCommerce

Resolved

BigCommerce engineers were alerted to elevated storefront errors starting around 15:35 UTC. The issue was resolved at 17:05 UTC and all systems are fully operational.
Posted Nov 13, 2025 - 11:24 CST

Monitoring

BigCommerce engineers have completed deploying a fix across the platform and are no longer observing elevated errors. We will continue to provide updates as they come through.
Posted Nov 13, 2025 - 11:15 CST

Identified

BigCommerce engineers have found the root cause of the issue and are deploying a fix. We will provide more information shortly.
Posted Nov 13, 2025 - 10:56 CST

Investigating

BigCommerce engineers are currently investigating intermittent availability issues with a subset of stores. We will provide an update shortly.
Posted Nov 13, 2025 - 10:20 CST
This incident affected: Storefront.