PayPal Commerce Platform 3DS popup infinite loading issue

Incident Report for BigCommerce

Resolved

External PayPal team identified an issue and fixed on their side, so PPCP 3DS authentication flow should work as expected on the UK stores
Posted Apr 09, 2026 - 12:24 CDT

Update

The Commerce development team is working closely with PayPal’s external team to identify the root cause of the issue.
Posted Apr 09, 2026 - 10:24 CDT

Investigating

Commerce team currently investigating an issue affecting PPCP 3DS authentication on the UK store. Some shoppers may experience an infinite loading state within the 3DS authentication popup, preventing completion of their transactions.
Posted Apr 09, 2026 - 09:53 CDT
This incident affected: Storefront.