Issue with B2B Edition

Incident Report for BigCommerce

Resolved

Commerce engineers have resolved the issue impacting B2B Edition from 4:25 pm UTC to 5:05 pm UTC and all services are fully operational.
Posted Jul 06, 2026 - 11:23 CDT

Investigating

Commerce engineers were alerted to an issue with B2B Edition and are currently investigating. We will provide updates as they become available.
Posted Jul 06, 2026 - 11:08 CDT
This incident affected: B2B Edition (B2B Edition - Dashboard).