Power Outage at Austin Contact Center
Incident Report for BigCommerce
Resolved
Power has been restored and all support channels are now fully available.
Posted Dec 07, 2018 - 15:10 CST
Identified
There is an Austin-area power outage affecting our contact center. We are working with our teams to optimize availability in alternate locations, but please expect delays in our Phone and Live Chat channels. Thank you for your understanding and patience.
Posted Dec 07, 2018 - 14:36 CST
This incident affected: Client Services (Support Center).