Phone System Degradation
Incident Report for BigCommerce
Resolved
Our provider has resolved the issue and all channels are now operating normally. Thank you for your patience.
Posted Jun 04, 2020 - 10:45 CDT
Monitoring
Our phone provider has implemented a fix and we are monitoring the results.
Posted Jun 04, 2020 - 10:23 CDT
Investigating
Our phone system is currently experiencing technical issues preventing agents from answering calls. We are working with our phone provider to remedy this, but in the interim please note our live chat and web case queues are available.
Posted Jun 04, 2020 - 09:17 CDT
This incident affected: Support Call Center.