Delayed Data in Analytics Reports

Incident Report for BigCommerce

Resolved

This incident has been resolved.
Posted Apr 24, 2026 - 10:07 CDT

Update

We are continuing to monitor recovery. We expect analytics data to catch up within the next 30 minutes.
Posted Apr 24, 2026 - 09:38 CDT

Monitoring

We are monitoring the results. We expect analytics data to be processed and caught up over the next 2 hours.
Posted Apr 24, 2026 - 08:32 CDT

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 24, 2026 - 08:29 CDT

Update

We are continuing to investigate this issue.
Posted Apr 24, 2026 - 08:07 CDT

Investigating

Commerce Engineers are investigating an issue where analytics data is delayed in the Control Panel Analytics Reports for a subset of stores.
Posted Apr 24, 2026 - 08:07 CDT
This incident affected: Reporting & Analytics.